Glentel Commissions Portal
Incident Report for Glentel
Resolved
Thank you for your patience. Maintenance is now complete.
Posted Nov 22, 2024 - 13:16 PST
Investigating
The Glentel commissions portal is now undergoing some emergency unscheduled maintenance. During this time, users may not be able to access current commission amounts on the portal. It is recommended that users refrain from using the portal until further notice.

No information will be lost and once completed, normal operations will recommence. Sales during the outage will be accounted for once the portal maintenance is complete.

Thank you for your cooperation.
Posted Nov 22, 2024 - 08:41 PST
This incident affected: Glentel Commissions Portal.