DUO Outage

Incident Report for Glentel

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 10:24 PDT

Monitoring

Microsoft has put in a fix for the issue. Users are now able to login again using DUO MFA to the Rogers portal. We will continue to monitor the situation in case there are any changes.
Posted Feb 23, 2026 - 08:27 PST

Update

Seems like the incident has been traced back to an outage at Microsoft. We're monitoring the issue with them and will update as information becomes available.
Posted Feb 23, 2026 - 07:56 PST

Investigating

There is currently an outage with any users using DUO for their Multi Factor Authentication. This may affect your ability to log into Carrier Portals as well as Email, Axonify and iConnect.

We're working with the vendor to solve this issue as quickly as possible.
Posted Feb 23, 2026 - 07:18 PST
This incident affected: Office 365 and Glentel Infrastructure Servers.