Microsoft Cloud Services Outage

Incident Report for Glentel

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 16:12 PST

Monitoring

Microsoft has put in a fix and is continuing to monitor their efforts. Our own tests confirm that external emails are now arriving, although there might be a slight delay.

Emails that were unable to be received during the outage may be delivered to your inbox as well. Please make sure you make note of the timestamp on these messages to know when they were sent.
Posted Jan 22, 2026 - 16:11 PST

Update

The outage continues. While they are working on it, there has been no concrete resolution yet.

Here is the latest message from Microsoft:

We're carefully rebalancing traffic across all affected infrastructure in the region, while monitoring the corresponding health telemetry, to ensure the environment enters into a balanced state as our remediation efforts continue. We’re proceeding as quickly as possible and this incremental approach will also help us identify whether any additional actions may be required to ensure longstanding recovery.
Posted Jan 22, 2026 - 14:29 PST

Investigating

Microsoft is currently experiencing an issue with its cloud services. Most notably, users may not be able to receive or send email messages.

Any support requests should be done through iConnect instead of email for the duration of the outage.

We are monitoring Microsoft's progress and will advise when it's cleared up.
Posted Jan 22, 2026 - 13:22 PST
This incident affected: Office 365.