Likewize Issues

Incident Report for Glentel

Resolved

IQ reports that MPP transactions are working again in the app.

If you experience any more issues, contact Retail Support and report them.
Posted Dec 06, 2025 - 14:44 PST

Update

IQ continues to investigate this with Likewize. The system is still down though, and any new enrollments will have to be done over the phone.
Posted Dec 06, 2025 - 14:29 PST

Update

Spoke too soon.....the outage continues. Both vendors have been contacted and are working on the issue.
Posted Dec 06, 2025 - 13:47 PST

Update

It appears the issue is now resolved.

If you continue to experience issues with Likewize and MPP, please contact Retail Support immediately so they can report it to the vendors. We will re-open this if necessary.
Posted Dec 06, 2025 - 12:20 PST

Investigating

We're currently seeing issues with Likewize and the payment portion of the transaction. Users will not be able to complete the transaction when it gets to the payment screen. Manual enrollments over the phone are also not currently working.

The vendor has been contacted and is working on the issue.
Posted Dec 06, 2025 - 10:42 PST
This incident affected: Likewize - Trade In/Repair.