IQ Errors and Slowdown

Incident Report for Glentel

Resolved

IQ's fix was successful. Operations are back to normal.
Posted Dec 02, 2025 - 15:38 PST

Identified

IQ has identified the issue. They are working towards implementation of a resolution and are seeing improvements.

We will continue to monitor their progress.
Posted Dec 02, 2025 - 15:09 PST

Investigating

IQ is currently investigating an issue that causes login and transaction errors. The issue is also causing slowdown ( latency ) within the application if you are able to get in.

This affects logins, transactions, integration and payments.
Posted Dec 02, 2025 - 14:51 PST
This incident affected: RQ Metrix POS.