IQ Slowdown

Incident Report for Glentel

Resolved

IQ has confirmed the fix worked and integration failures have stopped. Service levels are back to normal.
Posted Nov 28, 2025 - 14:11 PST

Monitoring

IQ has identified an issue with carrier integration which could result in slower transactions. They have already implemented a fix and are monitoring.

This is NOT an outage, but users may see that integration transaction may be a bit slower.
Posted Nov 28, 2025 - 13:32 PST
This incident affected: RQ Metrix POS.