DUO-iConnect Outage

Incident Report for Glentel

Update

Opterus ( iConnect ) is continuing work to rectify the issue in the mobile app.

Continue to use the web version at https://iconnect.opterus.net/login if you are unable to use the mobile app.
Posted Apr 14, 2026 - 09:14 PDT

Investigating

Users that have DUO as their Multi Factor Authenticator are not able to log into iConnect on their mobile devices. We are working with the vendors to rectify this issue. Users with Microsoft Authenticator are not affected.

The web version of iConnect is not experiencing any issues and you are able to use that. It is just the mobile version. You can find the web version at https://iconnect.opterus.net/login
Posted Apr 10, 2026 - 09:35 PDT
This incident affects: iConnect.